The minimum version of iOS required to run SYNCHRO Notes is iOS 13, and the device requirements are iPhone 8 and iPad Air or newer. Please check that you’ve upgraded to the latest iOS before trying to download the SYNCHRO Notes App from the app store.

Did this answer your question?