NoteVault currently supports all versions of Mozilla FireFox, Google Chrome, and Safari. Users using Internet Explorer will need version 8 or later.

Did this answer your question?